Jump to content
andi366

Flickering monitor

Recommended Posts

Hi, as soon when I start EFB2 the monitor starts to flicker (every 5 seconds a little black box appears for a millisecond. I have P3dv4 latest version and W10, also GTX 1070 Video card.

Thanx for any help. I happens with different planes (PMDG, Aerosoft) and different locations.

Kind regards Andrej

Share this post


Link to post
Share on other sites

Yes, I have the same problem !!?

I tested with all of my addons (enabled,disabled) - EFB2 causes this problem !

This constant flickering in the background is really disturbing !? 

 

any ideas ?

 

greetings

ggerolamo

Share this post


Link to post
Share on other sites

Unfortunately I cannot reproduce the behavior that you describe.

The presentation logic has not been changed since more than a year when the first version 2 came out. It's standard graphics operation of .NET managed code. Nothing suspicious. The only idea which comes to my mind is that the flickering may happen if EFB Client window is positioned in front of the simulator window (also just partially), but sorry, no ideas what else could cause this flickering.

 

 

Share this post


Link to post
Share on other sites

Thanks for the answer !
Normally I use efb2 on my 2nd screen. I have tried everything to that end...
I only notice this strange behavior since the last (or second last) update !? - a constantly flickering black bar in the middle of the screen 
unfortunately a complete showstopper :-(

Any idea ? Change any setting ?

 

Share this post


Link to post
Share on other sites

I also use it on my second screen. First time I recognized it was about 3 weeks ago. I assumed it had something to do with the driver or som updates in EFB. 

There is at least one other person having the issue (in the facebook P3D-group.

Kind regards Andrej

Share this post


Link to post
Share on other sites

So, for everyone who cares, i have found (for myself) a solution to the problem:

  1. Right-click the prepar3d.exe
  2. In the context menu, select Properties.
  3. Go to the Compatibility tab.
  4. Enable the option Disable fullscreen optimizations.

That worked great for me - no more flickering!!! :-)

 

greetings

ggerolamo

Share this post


Link to post
Share on other sites
On 10/10/2019 at 11:02 AM, ggerolamo said:

So, for everyone who cares, i have found (for myself) a solution to the problem:

  1. Right-click the prepar3d.exe
  2. In the context menu, select Properties.
  3. Go to the Compatibility tab.
  4. Enable the option Disable fullscreen optimizations.

That worked great for me - no more flickering!!! :-)

 

greetings

ggerolamo

Thanks Ggerolamo, for your troubleshooting! I have set this option already for quite some time due to another issue I had with P3D on a multi-screen setup not related to EFB. So in fact I didn't get aware that this could also be the issue here. At least it explains why I haven't seen it anymore  to-date.

We will include this proposal into our FAQ section.

Share this post


Link to post
Share on other sites

Hi Urs,

 

Same for me.  However, let me say that this only started following the latest Windows Build installation and subsequent update.  It has been working flawlessly for me up until that point.

 

I narrowed this down to EFB by disabling all my addons until the flickering disappeared.  And now I can reproduce it each and every time.  I´ve moved the EFB window around to ensure that it is not near the main Sim window ( 3 monitors) but still the flickering.  NB:  It´s only when the client is running;  ive not noticed any flickering with just the server.  It´s almost impossible to try and capture the screen as it happens at irregular but frequent intervals.

 

It is almost as if a message box is trying to load in the sim but disappears before it has time to load and all you get is a black line for less that a second. 

 

I have made the changes as suggested and will report back tomorrow.

 

Best regards,


Ken

 

Share this post


Link to post
Share on other sites

The way it looks I wasn't the only one with the problem ;-)
I also think, that this behavior was created with one of the last WINDOWS patches ! ..never had the problem before ...
I am happy, if the tip helped some others too :-)

greetings
ggerolamo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...