Jump to content
Martin Lee

EFB2 Flight Plan problem

Recommended Posts

When creating a flight plan in EFB2 for FSX-SE, for example a simple plan from EGHC to EGHE a distance of about 25 miles, EFB inserts a waypoint 20xT3 at a distance of 4182.84 miles instead of approx 25 miles. This will occur on any given route, not only this one. Any clues about this please?  BTW this does not occur in P3dV4

Share this post


Link to post
Share on other sites

Hi Martin,

could you please provide the flight plan (as EFB route, *.efbr) and please let us additionally know:

- which navdata provider is in use

- which AIRAC cycle

- what kind of waypoint is this ' 20xT3', and which way did you insert this waypoint

Share this post


Link to post
Share on other sites

Hi, Thank you for your reply. Attached is a copy of the flightplan. It appears to reveal nothing peculiar. However the Garmin GPS on the aircraft (any aircraft) shows the first waypoint as 20XT3 (which is the 3 mile runway extension from the destination arrival runway) at a distance pf 4182.84 NM, when it should be approx 25NM.

 

I'm using Navigraph current cycle.

 

Also without a flightplan, If I insert this 20XT3 runway extension directly from EFB, I get the same result. This will occur at any airport, not just the one in the example.

EGHCEGHE01.efbr

Share this post


Link to post
Share on other sites

Difficult to find out what happens on your system. So you're saying that the routing depiction is not as in the follwing screenshots? This routing is exactly following your description:

 

// AivlaSoft EFB v2 Route - www.aivlasoft.com
// Created 12.06.2019 12:19, EFB version: Version 2.1 (build #109)
Format=2
IcaoFpl =
From=EGHC
To=EGHE
Routing=EGHC DCT EGHE
CruiseAltitude=2000
Wpt=0|A|EGHC|50.102778|-5.670556||
Wpt=1|N|20XT3|50.053815|-5.699805||DCT
Wpt=2|A|EGHE|49.913334|-6.291667||DCT

 

Depiction on EFB V2:

EGHC_EGHE.png.041cc6dacf680b198234e5413e4ea885.png

 

Depiction on std GPS/GNS:

EGHC_EGHE_01.png.ea68dd2b3cb7706293e372434bb20037.png

Share this post


Link to post
Share on other sites
3 minutes ago, Martin Lee said:

Yes wpt=1 shows a mileage in excess of 4000nm in the simulator gps. This does not occur if using P3DV4

Martin,

 

A few questions though to narrow down possible causes for this misbehaviour:

- Is the Sim running?

- where is the A/C positioned?

- Could you post a screenshot from EFB v2 of this specific routing?

Share this post


Link to post
Share on other sites

Yes the sim is running.

The a/c is positioned at departure airport

Herewith 2 screenshots of EFB2 as requested plus 1 screenshot of FSX showing GPS with mileage to waypoint.

 

Thanks

EFB-1.jpg

EFB-2.jpg

FSX-1.jpg

Share this post


Link to post
Share on other sites

I'm sorry, but I'm still very confused. Nothing fits together in your setup.

 

1. There is no Waypoint 20XT3 in your Flightplan (1st screenshot)

2. There is no waypoint 20XT3 visible in the route (2nd screenshot)

3. There is no flightplan active in the GPS ( 3rd screenshot: *ppos -> 20XT3)

 

How did you get this wayoint into the GPS if there is no Flightplan active??

Share this post


Link to post
Share on other sites

EFB inserts the waypoint automatically irrespective of whether there is already a loaded flightplan or not. For example there is no flightplan loaded in the sim  and i click on airports in EFB and select EGHE and then PROC and arrivals then select the relevant runway and RWY ext-3, SET FPL and it gets inserted into the SIM GPS with the erroneous mileage.

 

Also if an a/c has an FMC it is not affected by the issue, for example aerosoft airbus or PMDG etc

Share this post


Link to post
Share on other sites

Well, this points to the fact that there is a missing setup in your EFB v2. This waypoint is not valid as it does not stem from an active Flightplan. In the GPS the first leg should read: RW20 ->  20XT3! So something is definitely wron in your initial EFB setup for FSX:SE.

 

Now this is getting a bit more complicated than I originally thought. We have first to find out why there is no flightplan loaded into the GPS, because this should happen automatically whenever a valid Flightplan is loaded. Please make a SupportFile from your Server to give us the chance to look at your settings.

Share this post


Link to post
Share on other sites

Unfortunately not 😀 This only contains Servier Information, but none of the whole setup. We need the ServerSupport File. You can generate it from the Windows Start Menu or from the Server -> System -> Settings and more... -> Press the Livesaver Button (support File):

 

SUPP.png.c4e9b9a853037e2dd6227a3d830dda75.png

Share this post


Link to post
Share on other sites

Yes, this one is correct. Can you check the following please: Go th the following folder: C:\Users\Martin\Documents\Flight Simulator X - Steam Edition Files\ and check whether there is a file named "EFB_current_gps.pln"

Share this post


Link to post
Share on other sites
1 hour ago, Martin Lee said:

Yes this file exists in the folder you mention and also in the folder flight simulator x files

"Flight simulator X files"? This folder should not exist if you are working with FSX:SE. Did you use EFB also with FSX at an earlier stage or do you mean "Prepar3D v4 Files"?

 

The problem is, that although the "EFB_current_gps.pln" exists, FSUIPC can obviously not read the path. Looking into the file "ServerSettings.txt", I see that the path for the FligtplanFolder is an UNC Path: "\\DESKTOP-BVFM6NN\Users\Martin\Documents\Flight Simulator X - Steam Edition Files\",  which is the network path of your main desktop computer. I have no idea, why this path is entered there. IMHO it should read: "C:\Users\Martin\Documents\Flight Simulator X - Steam Edition Files\" instead.

 

As this path is however entered automatically by EFB, I cannot say whether it can be changed safely into the abovementioned path name. It is a known fact that FSX has problems with UNC names. NeverthelessiIf you are familiar with text file editing, you might try to change this path in the "serverSettings.txt" file. Before doing so in any case make a backup copy of the "serverSettings.txt" file. Shut down EFB v2. Do not start editing as long as EFB v2 is running!

 

The file is to be found in "C:\Users\Martin\Documents\AivlaSoft\EFB2\Server\Settings"

 

Within that file look for section:

[SimulatorFsxSe]

 

Therein look for the line:

FlightplanFolder = \\DESKTOP-BVFM6NN\Users\Martin\Documents\Flight Simulator X - Steam Edition Files\

and change this line to:

FlightplanFolder = C:\Users\Martin\Documents\Flight Simulator X - Steam Edition Files\

 

Do not make any other changes and save the file. Then restart EFB v2.

 

Unfortunately I will be away for the next two days, however not completely off this world. So I will nevertheless have a look into the forum, just not as frequently as today. Nevertheless waiting for your report.

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...