Jump to content
SimPilotTrev

Server Does Not See Client on Networked PC

Recommended Posts

Hi

I have got an issue where the server is not seeing my network.  I have browsed the server manual and according to it, I should see under the server settings the following:

 

TCP network

IP address            any 'Change'

 

Port Number XYX

 

My problem is that the line IP address     any 'Change'  does not show.

 

Do you have a resolution to this problem please.

 

Thank You

Trevor

 

 

Aivlasoft EFB - Server not seeing Network.PNG

Share this post


Link to post
Share on other sites
51 minutes ago, SimPilotTrev said:

Hi

I have got an issue where the server is not seeing my network.  I have browsed the server manual and according to it, I should see under the server settings the following:

 

TCP network

IP address            any 'Change'

 

Port Number XYX

 

My problem is that the line IP address     any 'Change'  does not show.

 

Do you have a resolution to this problem please.

 

Thank You

Trevor

Hi Trevor,

This is not a problem. This entry has been deleted as it is not necessary at all (see updated User Guide "3 Server", page 14). You don't need this entry. The reason why your server is not seeing your network is not dependend on this IP address. You need to enter the proper IP address (or the computer's name) of your server's Computer in the Client's System window. The manuals were updated with the latest update.

Current builds are Server #58, Client #76.

Share this post


Link to post
Share on other sites

Hi Oskar

Sorry but I probably did not explain enough.  The Client and Server are talking and so the Client is working fine over the network.  However I was trying to point the server to Active Sky which is on the Slave PC but as you can see from the attached the paths to it are not showing.  This is only happening with EFB because when I use the normal Windows 10 file manager, the paths to my slave PC do show (see other attachment)Capture.PNG.5e7ce4eda3d5f1ef112af6dd14f99f11.PNG2142714812_Windows10View.thumb.PNG.57be9b7ed0cacc43cd55940c5b2377b1.PNG.  Hope this is a bit clearer.

Thank you

Trevor

Share this post


Link to post
Share on other sites
22 minutes ago, SimPilotTrev said:

Hi Oskar

Sorry but I probably did not explain enough.  The Client and Server are talking and so the Client is working fine over the network.  However I was trying to point the server to Active Sky which is on the Slave PC but as you can see from the attached the paths to it are not showing.  This is only happening with EFB because when I use the normal Windows 10 file manager, the paths to my slave PC do show (see other attachment).  Hope this is a bit clearer.

Thank you

Trevor

Trevor,

 

I must confess that I have no idea how you access your networked drives. Normally you will access it through the normal "network" path tree where you can access the ActiveSky "current_wx_snapshot.txt" file directly. The indicated path would then be like "\\<your network_pc>\c\users\<username>\AppData\Roaming\Hifi\XX_P3Dv4\Weather\current_wx_snapshot.txt. This is the usual way I also use on one of my installations.

Share this post


Link to post
Share on other sites

Hi Oskar

I can access the slave PC via the normal windows file explorer - see second caption which shows the word 'slave' near the bottom left.  However when I use the EFB Server file explorer, the 'slave' paths do not show.  I am therefore assuming it is something to do with the EFB server file explorer - see first caption of the two?

Thank you.

Trevor

 

 

 

Share this post


Link to post
Share on other sites

Trevor,

EFB has no own file explorer. It uses strictly the file explorer of the corresponding WinOS. As I see you don't use normal network drives, but mounted drives in your file structure. Have you ever clicked one of the DRIVEs in the file explorer opened by EFB? Mounted drives should appear as folders within the drive's file structure.

Share this post


Link to post
Share on other sites

Hi Oskar

Apologies for delay in getting back to you.  My PCs are correctly networked (see attached taken from the Master PC).  You can clearly see that I do in fact have networked drives and not mounted drives.  I have additionally checked with my PC builder to ensure I have my facts correct.  As previously explained (and for the benefit of Patrick who has also responded), the EFB Server use of the Windows 10 (latest version) File Explorer does not see the networked drives whereas using windows 10 File Explorer outside of the EFB server does see the networked drives.

 

Patrick seems to have an initial solution but I would rather not rollback my windows 10 version.  Is it likely that Aivlasoft will eventually resolve this or are there other avenues to explore please? 

Thank you

Trevor

Networked Drives.PNG

Share this post


Link to post
Share on other sites

Hi Trevor,

 

I have no problem to navigate through the entire network via the EFB Server's browser and select the ActiveSky file on another computer. EFB is using the default Windows browsing facility.

 

However, on your screenshots I can see some things which I guess point to some anomalies with the network, or the installation itself:

1) On the first screenshot I see three different folders for AivlaSoft and/or EFB. Usually this is all in one folder

2) What means "not seeing Network"

 

2018-09-24 21_29_00-Clipboard.png

 

2018-09-24 21_30_24-Clipboard.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...