Jump to content

No traffic in Traffic Monitor until vpilot connects


Recommended Posts

I know there is another thread about traffic issues, but this is different than what I see on that thread.  My issue is that I never see any traffic until I connect with vpilot.  I thought the traffic should be available on the ground before spawning on vatsim (pressing the connect button in vpilot).

 

More Info:

  • I have the latest versions of Aivlasoft server and client
  • I have ensured that all software (Aivlasoft, vpilot, sim (P3D 4.3) are running as administrator
  • The online setting in the server is pointing to http://status.vatsim.net/status.txt and I can reach that file from a browser
  • I read in another thread that starting vpilot and EFB server before starting sim may fix issue with no ground traffic, but this has not worked for me

 

I am using EFB 1 in conjunction with EFB 2 now as it still displays ground traffic before connecting in vpilot so I have an easy workaround, but any advice would be appreciated.

 

Thanks!

Link to comment
Share on other sites

Hello *YOURNAME* (https://forum.aivlasoft.com/topic/2522-forum-rules-read-before-post/)

 

 

EFB (and also your simulator) doesn't/don't know if you are connected to the network. To avoid overlay of "red" and "blue" traffic, no "red" traffic is displayed after the EFB has established connection to the sim (yellow text Simulator is gone) until it is shutdown.

Link to comment
Share on other sites

Jonas,

 

Thanks for the quick reply, and reminder about not signing my name.  My apologies.

 

I should have been clearer in my post.  The issue is with Traffic Monitor on the server side - I have no issue with colors in EFB ore with seeing traffic in EFB as long as Traffic Monitor is picking it up.  The Traffic Monitor will not detect vatsim traffic until vpilot connects.  As soon as I connect traffic appears, and as soon as I disconnect, it disappears from Traffic Monitor (and EFB, of course).

 

 Is it no longer possible to detect traffic before spawning?  From what I've read I thought we should still be able to see it.  The AI traffic worked flawlessly in version 1 - I could see traffic on the ground before I connected in vpilot which prevented me from spawning on other aircraft.  I can still use v1 for this purpose, or just not worry about spawning on other aircraft, but wanted to see if I've missed something in my configuration or if there is a bug.

 

Kint Regards,

 

Mark Glassman

Link to comment
Share on other sites

10 minutes ago, daveebee said:

I do not use Vpilot

Then this is not the right topic for you.

 

4 minutes ago, comjglassman said:

Is it no longer possible to detect traffic before spawning?  From what I've read I thought we should still be able to see it.  The AI traffic worked flawlessly in version 1 - I could see traffic on the ground before I connected in vpilot which prevented me from spawning on other aircraft.  I can still use v1 for this purpose, or just not worry about spawning on other aircraft, but wanted to see if I've missed something in my configuration or if there is a bug.

This is still possible with limitations.

 

Best practice

  • Start EFB server and client
  • RED AI traffic will be loaded and displayed (it takes a few seconds)
  • Start your sim
  • RED traffic will disappear when your scenario is loaded (but will stay when your sim is set up to show the "home/free flight" dialog first)

However, if you have been flying already before (sim was running), a return to the free flight dialog won't bring back the RED traffic. Simply, because there is no trigger for this. RED traffic then will only return when you close the sim.

 

Hope that helps.

Link to comment
Share on other sites

Thanks, Jonas.  I thought I tried this before as mentioned in the first post, but I will try again in a couple of hours.  I will give it a couple of minutes, also as I read that it may take time to get the vatsim update.  

 

Thanks again, and I'll update as soon as I can.

 

Mark Glassman

 

Link to comment
Share on other sites

14 hours ago, Mr. ATC said:

Then this is not the right topic for you.

 

This is still possible with limitations.

 

Best practice

  • Start EFB server and client
  • RED AI traffic will be loaded and displayed (it takes a few seconds)
  • Start your sim
  • RED traffic will disappear when your scenario is loaded (but will stay when your sim is set up to show the "home/free flight" dialog first)

However, if you have been flying already before (sim was running), a return to the free flight dialog won't bring back the RED traffic. Simply, because there is no trigger for this. RED traffic then will only return when you close the sim.

 

Hope that helps.

 

Hi jonas, is it possible to have the same  as EFB 1,  so when connected to sim won't cause live traffic to disappear (while vpilot is off).

 

 Thanks 

James.

Link to comment
Share on other sites

Hi Jonas,

 

I'm happy to report that I'm getting traffic in Traffic Monitor now and understand the new limitation, but it isn't bad.  The new version is a major upgrade (kudos), and it is no big deal to start EFB before the sim.   I sincerely appreciate your help, sir.

 

Regards,

 

Mark Glassman

Link to comment
Share on other sites

3 hours ago, Mr. ATC said:

As far as I understood Urs, this is not possible, mainly because EFB2 is using FSUIPC as interface, whereas EFB1 was using SimConnect.

 

Thanks. Happy with product.

james.

Link to comment
Share on other sites

  • 2 weeks later...

Hello,
Thank you very much for this prompt answer, but unfortunately I do not understand your answer.
should I run P3DV4? Is it in OPTIONS?
You see, I'm not very good at it and you have to hold your hand to make this manipulation happen.
Thank you for communicating the procedure in detail
Good night
Jean de Bordeaux

Link to comment
Share on other sites

1444452167.jpg

 

This is the screen. If the "show at startup" (bottom right) is activated, this screen will be shown when you start your sim and RED traffic will still be displayed at this time. As soon as you load the scenario or you load it directly when you run the sim (the "show at startup" option is disabled then), RED traffic will disappear.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...