Jump to content
natcret

Flight Plan Adj CRZ ALT Bug

Recommended Posts

It appears that there may be a bug related to adjusting the cruise altitude.  If I try to use the normal keyboard numbers to adjust the altitude, I can only use numbers 4-9 as the numbers 1-3 try to zoom or reset the map display in the map window.   Zero (0) works intermittently.   However, If I use the keypad, everything works fine.  Using FSX.

 

Regards,

 

Nat

Share this post


Link to post
Share on other sites

Check that the flight plan window (I assume this is where you change the altitude) is actually the active window. You didn't change by mistake the shortcut settings for the 3 zoom levels available in the client settings, register "Shortcuts"?

Share this post


Link to post
Share on other sites

Thank you for the response.  Nope, no changes to any of the shortcut settings.  The Flight Plan Window is the Active Window (Black border around the window).  I tried again this evening wiht nothing loaded simulator-related and I had the same issue. 

 

Steps I took:

 

1. Start the Server then the Client...no issues.

2. Clicked on FPL and loaded a Company Route.  All ok.

3. The Flight Plan Window opens with the route legs shown.

4. I click on "Adj CRZ ALT" and I cannot type in the numbers 1, 2,3 or 0 using the top of the keyboard.  However, I can enter the numbers using the numeric keypad.

Again this is the strangest thing I have ever seen and I am no stranger to the flight sim word and add-ons.

 

Just to make sure I cover all items,  while flying, climbing to my cruise altitude and then clicking on "Adj CRZ ALT" via the RSB works as advertised (page 36 of the Flight Plan Doc).

 

Regards

Share this post


Link to post
Share on other sites

Just use the numeric keypad. That works all the time or use the respective RSB button inflight after reaching the cruise altitude.

Share this post


Link to post
Share on other sites

Thank you Lonewulf.  Yes, I will probably continue to use the keypad, however, that does not address the issue.  Maybe mine is an isolated case as no one else seems to have this issue.

Share this post


Link to post
Share on other sites

Is this limited to EFB or would also other applications like a basic text editor, when you run it in the described scenario, refuse to accept 1-3? Do you have an app installed for key mappings or could it be an interference with other apps? Is the behaviour the same when your complete sim environment is running or if you do a try just with the EFB running.

Share this post


Link to post
Share on other sites

I apologize for the long delay.  I have checked through everything.   All hardware disconnected, no applications running.  Just the server and client and it flat refuses to accept keyboard entry of the numbers 1-3 and 0.   And as stated earlier, when entering numbers using the numeric keypad instead, no issues at all.

Share this post


Link to post
Share on other sites

No need to apologize.

How about a simple text editor? So when you try to enter numbers from 1-3 in EFB and it doesn't work, quickly open a text editor and try to type numbers there. Does that work? I just want to be sure to exclude any strange input commands from the keyboard (either due to the keyboard hardware or the driver on your computer).

 

If there is no such behaviour in other apps than EFB, I would suggest to re-install the EFB client (if you haven't tried that). Not really sure if that can help anything, but I'm running out of ideas slowly but surely.

Share this post


Link to post
Share on other sites

I tried the test editor.  No issues..typed just fine.  i have no other issues with any other add-ons or applications.   I can live with using the keypad.  I will try a reinstall, however, and see if it clears up.

 

Thank you again!  I will let you know what happens.

Share this post


Link to post
Share on other sites

As a follow up, I uninstalled and reinstalled the client.  Unfortunately the issue still persists...however...

 

On a whim, I went into settings and removed the default zoom key settings (D0, D1,D2,D3) and then tried again.   Everything worked!  So it seems, at least in my case, that there is a conflict between the default zoom keypress settings and the ability to enter the numbers to Adj CRUZ ALT using a keypress instead of the keypad.

 

Regards. 

Share this post


Link to post
Share on other sites
On 7/15/2018 at 2:22 PM, Mr. ATC said:

Thanks for the update! Does the issue return when you set those zoom key settings again?

 

Again, I apologize for the delayed response (real life at work).  I re-tested by assigning the keys back to their original settings and the issue returned.  I also did another test by assigning new number keys (6,7,8,9,) to the Zoom Auto and User settings.  Well, 1,2 3, and 0 now work, however 6,7,8, and 9 does not.  Again, this is all using the keyboard.  When I use the Keypad on the keyboard, all is well.

 

Regards

 

Nat

Share this post


Link to post
Share on other sites
On 7/15/2018 at 7:17 PM, natcret said:

So it seems, at least in my case, that there is a conflict between the default zoom keypress settings and the ability to enter the numbers to Adj CRUZ ALT using a keypress instead of the keypad.

This is not a conflict, this is by design. A shortcut is always taken first, before the key is forwarded to the other controls like the spin edit for the altitude. If you would like to use the numeric keys on the keyboard to enter the altitude (or any other textbox), then you have to remove such shortcuts which are also using the numeric keys from the keyboard.

Share this post


Link to post
Share on other sites

Urs,

 

Understood.  Thank you very much for the explanation.  Since this is solved may I recommend locking the topic.

 

Great support as always!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×