Jump to content
busychild

Database Builder - Errors

Recommended Posts

Hi,

 

i get errors while running the database builder:

 

"Database creation finished with 6 warning(s) and/or 2 error(s). ...".

 

The logfile shows some warnings about missing add-on.xml files but also the following errors:

 

2018-07-01 01:04:26.395   Debug   : Start scanning 23156 files
2018-07-01 01:04:33.043   Debug   : Navaids read: 22069
2018-07-01 01:04:33.045   Debug   : Airspaces read: 46084
2018-07-01 01:04:33.046   Debug   : Airports read: 24625
2018-07-01 01:04:33.048   Debug   : Creating navaids repository ...
2018-07-01 01:04:33.488   Error   : Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
2018-07-01 01:04:33.554   Debug   : Reading magdec.bgl OK
2018-07-01 01:04:33.554   Debug   : Writing magvar.bin ...
2018-07-01 01:04:33.563   Debug   : Writing magvar.bin OK
2018-07-01 01:04:33.564   Debug   : Reading Navigraph FMS Data, cycle 1802 Rev 1 ...
2018-07-01 01:04:35.120   Debug   : --> Merging simulator and navdata P3Dv4/NG
2018-07-01 01:04:35.124   Error   : Die Datei "C:\Users\Florian\Documents\AivlaSoft\EFB2\Server\DbBuilder\Base\P3D4\comservices.bin" konnte nicht gefunden werden.
2018-07-01 01:04:36.045   Warning : Database creation finished with 6 warning(s) and/or 2 error(s).

 

If i ignore the errors and start the server a message comes up: "Trying to verify demo license but could not reach any time server on the internet.".

If i then click "ok" and enter my data again the license could be validated but a new error comes up "Could not read database due to errors. Please see the logfile."

 

The serverLogfilter.txt contains the following error (which is much likely caused by the issue of the database builder):

 

2018-07-01 01:08:30.200   Debug   : Loading database ...
2018-07-01 01:08:30.205   Error   : Die Datei "C:\Users\Florian\Documents\AivlaSoft\EFB2\Server\DbBuilder\Ready\P3Dv4NG\airports.bin" konnte nicht gefunden werden.     bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)   bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)   bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)   bei z.z.g.u.g.nn(String A_0, Action`1 A_1)     bei z.z.g.u.g.nn(String A_0, Action`1 A_1)   bei z.z.z.g.i.m()
2018-07-01 01:09:04.463   Debug   : Server settings saved to: C:\Users\Florian\Documents\AivlaSoft\EFB2\Server\Settings\serverSettings.txt
2018-07-01 01:09:04.465   Debug   : ========== Terminated ==========

 

PS: I attached the debug package.

 

Any ideas?

 

Best regards

 

Florian

Server_201807010111.txt.zip

Share this post


Link to post
Share on other sites

Same issue

2018-07-01 00:43:26.092   Debug   : Start scanning 51374 files
2018-07-01 00:51:25.944   Debug   : Navaids read: 36148
2018-07-01 00:51:25.952   Debug   : Airspaces read: 72952
2018-07-01 00:51:25.965   Debug   : Airports read: 26485
2018-07-01 00:51:25.978   Debug   : Creating navaids repository ...
2018-07-01 00:51:26.398   Error   : Object reference not set to an instance of an object.
2018-07-01 00:51:26.518   Debug   : Reading magdec.bgl OK
2018-07-01 00:51:26.524   Debug   : Writing magvar.bin ...
2018-07-01 00:51:26.568   Debug   : Writing magvar.bin OK
2018-07-01 00:51:26.594   Debug   : Reading Navigraph FMS Data, cycle 1802 Rev 1 ...
2018-07-01 00:51:31.223   Debug   : --> Merging simulator and navdata P3Dv4/NG
2018-07-01 00:51:31.257   Error   : Could not find file 'C:\Users\Administrator\Documents\AivlaSoft\EFB2\Server\DbBuilder\Base\P3D4\comservices.bin'.
2018-07-01 00:51:32.670   Warning : Database creation finished with 1 warning(s) and/or 2 error(s).
2018-07-01 00:52:24.706   Debug   : Server settings saved to: C:\Users\Administrator\Documents\AivlaSoft\EFB2\Server\Settings\serverSettings.txt
2018-07-01 00:52:24.718   Debug   : ========== Terminated ==========
2018-07-01 00:52:24.724   Debug   : 

 

Share this post


Link to post
Share on other sites
19 minutes ago, ZKOKQ said:

As above, same issues.

The database tool works from within the server, but not stand alone

 

For me it doesn‘t work - regardless of if i‘m starting the database builder from the server app or stand alone...

Share this post


Link to post
Share on other sites
3 minutes ago, busychild said:

 

For me it doesn‘t work - regardless of if i‘m starting the database builder from the server app or stand alone...

Yes, now it is the same for me. It is now going around an  eternal loop. Not a good start.

Share this post


Link to post
Share on other sites

I am just trying the 1807 airac, copied over from EFBv1, and all good now. Must be problem with airac 1802. Still the Lic issue though

 

2018-07-01 12:09:55.579   Debug   : ========== AivlaSoft.Efb.DbBuilder 2.0.50.0 started ==========
2018-07-01 12:09:55.618   Debug   : Settings loaded from: C:\Users\Mick\Documents\AivlaSoft\EFB2\Server\Settings\serverSettings.txt
2018-07-01 12:09:56.038   Debug   : Verify license ...
2018-07-01 12:09:59.267   Debug   : Trial version running, trial will end in 29 days.
2018-07-01 12:10:15.665   Debug   : --> Updating AIRAC cycle
2018-07-01 12:10:15.665   Debug   : --> Database P3Dv4.NG-1802/R1
2018-07-01 12:10:15.669   Debug   : Reading Navigraph FMS Data, cycle 1807 Rev 1 ...
2018-07-01 12:10:18.295   Debug   : Reading P3Dv4 data ...
2018-07-01 12:10:24.524   Debug   : --> Merging simulator and navdata P3Dv4/NG
2018-07-01 12:10:24.538   Debug   : COM services and airspaces copied
2018-07-01 12:10:25.287   Debug   : Adding additional waypoints ...
2018-07-01 12:10:27.638   Debug   : Verifying airways data ...
2018-07-01 12:10:28.895   Debug   : Verifying procedures data ...
2018-07-01 12:10:35.217   Debug   : Creating runway mapping table
2018-07-01 12:10:35.954   Debug   : Runway mappings created for 1126 airports. See C:\Users\Mick\Documents\AivlaSoft\EFB2\Server\Logfiles\runwayMappings_P3Dv4-NG.txt
2018-07-01 12:10:35.968   Debug   : Getting ILS categories
2018-07-01 12:10:36.674   Debug   : Getting ARINC magvar
2018-07-01 12:10:37.888   Debug   : Writing cycleInfo.txt ...
2018-07-01 12:10:37.894   Debug   : Applying data changes ...
2018-07-01 12:10:38.204   Debug   : Writing airports.bin ...
2018-07-01 12:10:40.317   Debug   : Compressing airports.bin ...
2018-07-01 12:10:44.063   Debug   : Writing airways.bin ...
2018-07-01 12:10:44.121   Debug   : Writing navaids.bin ...
2018-07-01 12:10:44.460   Debug   : Merging simulator and navdata OK
2018-07-01 12:10:44.529   OK      : Database creation successfully finished.
2018-07-01 12:18:15.004   Debug   : Server settings saved to: C:\Users\Mick\Documents\AivlaSoft\EFB2\Server\Settings\serverSettings.txt
2018-07-01 12:18:15.014   Debug   : ========== Terminated ==========
2018-07-01 12:18:15.014   Debug   :

 

Share this post


Link to post
Share on other sites

Gentlemen, you certainly understand that we cannot provide a 24-hours service ?. It's now 2:56 AM here in Switzerland. You will have to wait for Urs to come online on Sunday, July 1st,  to provide assistance for these errors in database building.

 

As far as the reported Warning messages about missing "Add-on.xml" files are concerned, there seems to be a problem within the installation of add-ons into P3D V4's package system. This is beyond EFB v2 influence. An improper (or manually changed) installation can cause havoc if not strictly adhered to the rules outlined by Lockheed Martin's SDK

http://www.prepar3d.com/SDKv4/sdk/add-ons/add-on_packages.html.  Neverhteless EFB v2's functions are not affected. The respective airport ground map will simply show the default layout.

Share this post


Link to post
Share on other sites
1 minute ago, lonewulf47 said:

Gwntlemen, you certainly understand that we cannot provide a 24-hours service ?. It's now 2:56 AM here in Switzerland. You will have to wait for Urs to come online on Sunday, July 1st,  to provide assistance for these errors in database building.

 

As far as the reported Warning messages about missing "Add-on.xml" files are concerned, there seems to be a problem within the installation of add-ons into P3D V4's package system. This is beyond EFB v2 influence. An improper (or manually changed) installation can cause havoc if not strictly adhered to the rules outlined by Lockheed Martin's SDK

http://www.prepar3d.com/SDKv4/sdk/add-ons/add-on_packages.html.  Neverhteless EFB v2's functions are not affected. The respective airport ground map will simply show the default layout.

Was not expecting an answer straight away Oskar. All good now though using airac 1807. I did not have the addon.xml error though, but would be a good idea for the OP to download Lorby's  xml app and that will check for errors.

Share this post


Link to post
Share on other sites
20 minutes ago, ZKOKQ said:

Was not expecting an answer straight away Oskar. All good now though using airac 1807. I did not have the addon.xml error though, but would be a good idea for the OP to download Lorby's  xml app and that will check for errors.

Be careful with any add-ons that manipulate the scenery_add-ons.xml and scenery.cfg. We still recommend to use the standard installation method using Lockheed Martin's package system.

Addons like Lorby's Organizer or SceneryConfigEditor may work the way it is intended, however be advised that whenever they edit one of the mentioned files, EFB v2 will ask you to rebuild the database.

Share this post


Link to post
Share on other sites
1 hour ago, hrsemn said:

I am having the same exact problem only with FSX-SE. Please help. RYAN

...

Hi Ryan,

Is this screenshot from the first run to create the database after initial Installation? Are you sure you followe EXACTLY the procecures laid down in the various User Guides? I see that you are in the "Update Simulator" tab.When creating a database for the first time you should be in the "Create/Select Database" tab.

Share this post


Link to post
Share on other sites

STOP STOP STOP !

Please make sure that you follow EXACTLY the procedures laid down in the Installation- and Quickstart Guide. More thorough information about the database building process can also be found in the Database guide.

 

Please do also not do anything that is not explicitly recommended by AivlaSoft to avoid initial errors. We have checked the installers many time before release and we did not encounter any of the reported errors. We will have to analyse the reports to see what exactly caused these reports.

 

Furthermore we would like to remind you to our Forum Rules, where it is mandatory to sign your posts with your (at least first) real name.

 

Please also state in your reports the Simulator(s) used and whether EFB v2 is installed in the default path.

We will do our best to solve the encountered problems but we will of course also require as much information about your installation.

 

Thank you for your understanding.

 

Share this post


Link to post
Share on other sites

First, the Database Builder throws "Error: Object reference not set to an instance of an object" just after creating the navaids repository and before reading magdec.bgl

 

The next error is: "Error: Could not find file D:\jeff\Documents\AivlaSoft\EFB2\Server\DbBuilder\Base\P3D4\comservices.bin"

 

This is where this chokes each time.  EFB2 unusable at the moment.

 

EFB is not installed in the default path.

 

Thank you,

 

Jeff

Share this post


Link to post
Share on other sites
22 minutes ago, ahuimanu said:

comservices.bin is not installed in D:\jeff\Documents\AivlaSoft\EFB2\Server\DbBuilder\Base

 

This is where this chokes each time.  EFB2 unusable at the moment.

 

EFB is not installed in the default path.

 

Thank you,

 

Jeff

Very strange. I just deleted my database and let EFB v2 rebuild the new database from scratch. I don't see any such behaviour.

What Simulator and OS are you running?

Share this post


Link to post
Share on other sites
4 minutes ago, lonewulf47 said:

Very strange. I just deleted my database and let EFB v2 rebuild the new database from scratch. I don't see any such behaviour.

What Simulator and OS are you running?

Hello,

 

Windows 10 and Prepar3d 4.3

 

Jeff

DbBuilder Error.PNG

Share this post


Link to post
Share on other sites
9 minutes ago, ahuimanu said:

Hello,

 

Windows 10 and Prepar3d 4.3

....

Jeff

 

Ok I see. Thanks, Jeff, for the info. Could you do me a favour and de- and reinstall EFB v2 to its default path and check and report again? Should be a matter of a few minutes. Although we have also checked remote installs I would like to make sure where this strange behaviour stems from.

Share this post


Link to post
Share on other sites

Hello Oskar,

 

Thank you.  I have already done this a few times earlier based on your reply to another user.  Thus, regardless of whether I have it installed in Program Files, or elsewhere, the behavior is the same.

 

It is the problem reported by the OP (error messages look identical save for language localization).

Thank you,

 

Jeff

Share this post


Link to post
Share on other sites

Oh, and just another thought: wnat kind of AV software do you use? Could it be that the AV software deletes this "comservice.bin" upon creation? It wouldn't be the first time that AV software play havoc with binary files (not only in EFB) by deleting it without any warning.

Share this post


Link to post
Share on other sites
3 minutes ago, ahuimanu said:

Hello Oskar,

 

Thank you.  I have already done this a few times earlier based on your reply to another user.  Thus, regardless of whether I have it installed in Program Files, or elsewhere, the behavior is the same.

 

It is the problem reported by the OP (error messages look identical save for language localization).

Thank you,

 

Jeff

Yes, I see the messages being identical, however this "comservices.bin" file is created within the database building process. Therefore it is hardly believeable that it simply "disappears"...?

Share this post


Link to post
Share on other sites

Hello Oskar,

 

Thank you.  I understand.  Perhaps both the OP and I are experiencing the same problem?

 

Thank you,

 

Jeff

Share this post


Link to post
Share on other sites
4 minutes ago, ahuimanu said:

Hello Oskar,

 

Thank you.  I understand.  Perhaps both the OP and I are experiencing the same problem?

 

Thank you,

 

Jeff

Yes. possible. In any case Windows Defender is not responsible for that as I use it here too. Could you possibly create an exception for the "comservices.bin"  file in your malwarebytes application to check? It is very strange that this file should disappear "just like this". So far I have never seen happening this and when I recreate my database I don't see any problems with that file either.

In any case we will have to wait for Urs to "come alive" here. He has more insight as to when exactly the file is created and under what conditions.

Share this post


Link to post
Share on other sites

Thank you Oskar,

 

I re-ran everything without MalwareBytes or Defender running and behavior is not different.

 

Thank you for working with me and perhaps Urs can make it better.

 

Jeff

Share this post


Link to post
Share on other sites
11 minutes ago, ahuimanu said:

Thank you Oskar,

 

I re-ran everything without MalwareBytes or Defender running and behavior is not different.

 

Thank you for working with me and perhaps Urs can make it better.

 

Jeff

Ok, thanks for info. Gotta get some sleep now after this "night shift" ? I'm sure Urs will be around soon to take over to solve the problems.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...